use strict;
my $str = '2
// no match
29.2
// no match
2.48
8.06.16
// no match
-2.41
-.54
// no match
4.492
// no match
4.194,32
39,299.39
329.382,39
-188.392,49
293.392,193
// no match
-.492.183,33\'
// no match
3.492.249,11
29.439.834,13
-392.492.492,43
8.06.16
// no match';
my $regex = qr/^-?\d{1,3}(?:[,.]\d{3})*[.,]\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}