using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=~\s\[)([a-zA-Z0-9\.]+)(?::)[^]]+";
string input = @"3 INFO ~ [com.Engine:164] italics";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}