re = /(?<=~\s\[)([a-zA-Z0-9\.]+)(?::)[^]]+/
str = '3 INFO ~ [com.Engine:164] italics'
# Print the match result
str.match(re) do |match|
puts match.to_s
end