# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b(DIN)|(DIN EN)|(DIN EN ISO)|(DIN ISO)|(DIN-EN)|(DIN-EN-ISO)|(DIN-ISO)|(EN)|(IEC)|(ISO)|(NEN)|(NEN‑EN)|(NEN‑EN‑IEC)\b)(\s)(\d)/$1‡$3/gm;t' <<< "You can find the specifications in DIN 12345, DIN EN 12345, DIN EN ISO 12345, DIN ISO 12345, DIN-EN 12345, DIN-EN-ISO 12345, DIN-ISO 12345, EN 12345, IEC 12345, ISO 12345, NEN 12345, NEN‑EN 12345, NEN‑EN‑IEC 12345."