const regex = /(\b(DIN)|(DIN EN)|(DIN EN ISO)|(DIN ISO)|(DIN-EN)|(DIN-EN-ISO)|(DIN-ISO)|(EN)|(IEC)|(ISO)|(NEN)|(NEN‑EN)|(NEN‑EN‑IEC)\b)(\s)(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(DIN)|(DIN EN)|(DIN EN ISO)|(DIN ISO)|(DIN-EN)|(DIN-EN-ISO)|(DIN-ISO)|(EN)|(IEC)|(ISO)|(NEN)|(NEN‑EN)|(NEN‑EN‑IEC)\\b)(\\s)(\\d)', 'gm')
const str = `You can find the specifications in DIN 12345, DIN EN 12345, DIN EN ISO 12345, DIN ISO 12345, DIN-EN 12345, DIN-EN-ISO 12345, DIN-ISO 12345, EN 12345, IEC 12345, ISO 12345, NEN 12345, NEN‑EN 12345, NEN‑EN‑IEC 12345.`;
const subst = `$1‡$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);