import re
regex = re.compile(r"(\b(DIN)|(DIN EN)|(DIN EN ISO)|(DIN ISO)|(DIN-EN)|(DIN-EN-ISO)|(DIN-ISO)|(EN)|(IEC)|(ISO)|(NEN)|(NEN‑EN)|(NEN‑EN‑IEC)\b)(\s)(\d)", flags=re.MULTILINE)
test_str = "You can find the specifications in DIN 12345, DIN EN 12345, DIN EN ISO 12345, DIN ISO 12345, DIN-EN 12345, DIN-EN-ISO 12345, DIN-ISO 12345, EN 12345, IEC 12345, ISO 12345, NEN 12345, NEN‑EN 12345, NEN‑EN‑IEC 12345."
subst = "$1‡$3"
result = regex.sub(subst, test_str)
if result:
print(result)