import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(https?://\\S+))(?|\\1 \\[([^]]+)\\]|(\\1))";
final String string = "http://stackoverflow.com/ [click here] bla bla bla\n"
+ "http://www.google.com/ bla bla bla";
final String subst = "<a href=\"$1\">$2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}