import Foundation
let pattern = #"(?=(https?://\S+))(?|\1 \[([^]]+)\]|(\1))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://stackoverflow.com/ [click here] bla bla bla
http://www.google.com/ bla bla bla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$1">$2</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)