$re = '~(?=(https?://\S+))(?|\1 \[([^]]+)\]|(\1))~';
$str = 'http://stackoverflow.com/ [click here] bla bla bla
http://www.google.com/ bla bla bla';
$subst = "<a href=\"$1\">$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;