package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]{2}[0-9]{6}|[0-9]{8})?$`)
var str = `ab123456
12345678
SH123456
12345678
sd456565
S2D3E4F5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}