import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{2}[0-9]{6}|[0-9]{8})?$";
final String string = "ab123456\n"
+ "12345678\n\n"
+ "SH123456\n"
+ "12345678\n"
+ "sd456565\n\n"
+ "S2D3E4F5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}