const regex = /^([a-zA-Z]{2}[0-9]{6}|[0-9]{8})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]{2}[0-9]{6}|[0-9]{8})?$', 'gm')
const str = `ab123456
12345678
SH123456
12345678
sd456565
S2D3E4F5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}