#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""X":"([0-9.]*)","Y":"([0-9.]*)""
Local $sString = "{"SearchResults":[{"PageCount":"0"}," & @CRLF & _
"{"SEARCHVAL":"530106","CATEGORY":"Building"," & @CRLF & _
" "X":"103.8907","Y":"1.3537"}]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")