using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""X"":""([0-9.]*)"",""Y"":""([0-9.]*)""";
string input = @"{""SearchResults"":[{""PageCount"":""0""},
{""SEARCHVAL"":""530106"",""CATEGORY"":""Building"",
""X"":""103.8907"",""Y"":""1.3537""}]}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}