import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"X\":\"([0-9.]*)\",\"Y\":\"([0-9.]*)\"";
final String string = "{\"SearchResults\":[{\"PageCount\":\"0\"},\n"
+ "{\"SEARCHVAL\":\"530106\",\"CATEGORY\":\"Building\",\n"
+ " \"X\":\"103.8907\",\"Y\":\"1.3537\"}]}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}