#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\s+\d{1,}"
Local $sString = "172.30.10.10 10 (acceptable)" & @CRLF & _
"172.30.10.1010 (not acceptable)" & @CRLF & _
"10 10 (not acceptable)" & @CRLF & _
"10 172.30.10.10 (not acceptable)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")