package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\s+\d{1,}`)
var str = `172.30.10.10 10 (acceptable)
172.30.10.1010 (not acceptable)
10 10 (not acceptable)
10 172.30.10.10 (not acceptable)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}