$re = '/\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\s+\d{1,}/';
$str = '172.30.10.10 10 (acceptable)
172.30.10.1010 (not acceptable)
10 10 (not acceptable)
10 172.30.10.10 (not acceptable)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);