#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)\s*<key>GA\X*<\/dict>"
Local $sString = "<dict>" & @CRLF & _
" <key>account.logout</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>GA</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>action</key>" & @CRLF & _
" <string>ButtonPressed</string>" & @CRLF & _
" <key>category</key>" & @CRLF & _
" <string>Account</string>" & @CRLF & _
" <key>label</key>" & @CRLF & _
" <string>Logout</string>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>MP</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>name</key>" & @CRLF & _
" <string>account logged out</string>" & @CRLF & _
" <key>people</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>__set__</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>logged into account</key>" & @CRLF & _
" <false/>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>properties</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>_flow</key>" & @CRLF & _
" <string>login</string>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>ABOY</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>name</key>" & @CRLF & _
" <string>account_logout_free2move</string>" & @CRLF & _
" <key>people</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>logged_in_to_free2move</key>" & @CRLF & _
" <false/>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>account.notification.create.facebook</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>GA</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>action</key>" & @CRLF & _
" <string>ButtonPressed</string>" & @CRLF & _
" <key>category</key>" & @CRLF & _
" <string>Account</string>" & @CRLF & _
" <key>label</key>" & @CRLF & _
" <string>Create Facebook</string>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>MP</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>name</key>" & @CRLF & _
" <string>create account pressed</string>" & @CRLF & _
" <key>properties</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>_account_type</key>" & @CRLF & _
" <string>facebook</string>" & @CRLF & _
" <key>_flow</key>" & @CRLF & _
" <string>login</string>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>account.notification.create.success.facebook</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>GA</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>action</key>" & @CRLF & _
" <string>AccountCreatedSuccessful</string>" & @CRLF & _
" <key>category</key>" & @CRLF & _
" <string>Account</string>" & @CRLF & _
" <key>label</key>" & @CRLF & _
" <string>Facebook</string>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>MP</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>name</key>" & @CRLF & _
" <string>create account success</string>" & @CRLF & _
" <key>people</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>__set__</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>account type</key>" & @CRLF & _
" <string>facebook</string>" & @CRLF & _
" <key>logged into account</key>" & @CRLF & _
" <true/>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>__set_current_timestamp__</key>" & @CRLF & _
" <string>last logged in account</string>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>properties</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>_account_type</key>" & @CRLF & _
" <string>facebook</string>" & @CRLF & _
" <key>_flow</key>" & @CRLF & _
" <string>account</string>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>ABOY</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>name</key>" & @CRLF & _
" <string>account_created_free2move</string>" & @CRLF & _
" <key>people</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>logged_in_to_free2move</key>" & @CRLF & _
" <true/>" & @CRLF & _
" <key>has_free2move_account</key>" & @CRLF & _
" <true/>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>properties</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>account_type</key>" & @CRLF & _
" <string>facebook</string>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>account.notification.declined</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>GA</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>action</key>" & @CRLF & _
" <string>ButtonPressed</string>" & @CRLF & _
" <key>category</key>" & @CRLF & _
" <string>Account</string>" & @CRLF & _
" <key>label</key>" & @CRLF & _
" <string>Later</string>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>MP</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>name</key>" & @CRLF & _
" <string>later pressed</string>" & @CRLF & _
" <key>properties</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>_flow</key>" & @CRLF & _
" <string>account</string>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" </dict>" & @CRLF & _
" <key>account.notification.shown</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>GA</key>" & @CRLF & _
" <dict>" & @CRLF & _
" <key>action</key>" & @CRLF & _
" <string>DialogueShown</string>" & @CRLF & _
" <key>category</key>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")