using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?U)\s*<key>GA\X*<\/dict>";
string input = @"<dict>
<key>account.logout</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>ButtonPressed</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Logout</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>account logged out</string>
<key>people</key>
<dict>
<key>__set__</key>
<dict>
<key>logged into account</key>
<false/>
</dict>
</dict>
<key>properties</key>
<dict>
<key>_flow</key>
<string>login</string>
</dict>
</dict>
<key>ABOY</key>
<dict>
<key>name</key>
<string>account_logout_free2move</string>
<key>people</key>
<dict>
<key>logged_in_to_free2move</key>
<false/>
</dict>
</dict>
</dict>
<key>account.notification.create.facebook</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>ButtonPressed</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Create Facebook</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>create account pressed</string>
<key>properties</key>
<dict>
<key>_account_type</key>
<string>facebook</string>
<key>_flow</key>
<string>login</string>
</dict>
</dict>
</dict>
<key>account.notification.create.success.facebook</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>AccountCreatedSuccessful</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Facebook</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>create account success</string>
<key>people</key>
<dict>
<key>__set__</key>
<dict>
<key>account type</key>
<string>facebook</string>
<key>logged into account</key>
<true/>
</dict>
<key>__set_current_timestamp__</key>
<string>last logged in account</string>
</dict>
<key>properties</key>
<dict>
<key>_account_type</key>
<string>facebook</string>
<key>_flow</key>
<string>account</string>
</dict>
</dict>
<key>ABOY</key>
<dict>
<key>name</key>
<string>account_created_free2move</string>
<key>people</key>
<dict>
<key>logged_in_to_free2move</key>
<true/>
<key>has_free2move_account</key>
<true/>
</dict>
<key>properties</key>
<dict>
<key>account_type</key>
<string>facebook</string>
</dict>
</dict>
</dict>
<key>account.notification.declined</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>ButtonPressed</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Later</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>later pressed</string>
<key>properties</key>
<dict>
<key>_flow</key>
<string>account</string>
</dict>
</dict>
</dict>
<key>account.notification.shown</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>DialogueShown</string>
<key>category</key>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}