use strict;
my $str = '<dict>
<key>account.logout</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>ButtonPressed</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Logout</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>account logged out</string>
<key>people</key>
<dict>
<key>__set__</key>
<dict>
<key>logged into account</key>
<false/>
</dict>
</dict>
<key>properties</key>
<dict>
<key>_flow</key>
<string>login</string>
</dict>
</dict>
<key>ABOY</key>
<dict>
<key>name</key>
<string>account_logout_free2move</string>
<key>people</key>
<dict>
<key>logged_in_to_free2move</key>
<false/>
</dict>
</dict>
</dict>
<key>account.notification.create.facebook</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>ButtonPressed</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Create Facebook</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>create account pressed</string>
<key>properties</key>
<dict>
<key>_account_type</key>
<string>facebook</string>
<key>_flow</key>
<string>login</string>
</dict>
</dict>
</dict>
<key>account.notification.create.success.facebook</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>AccountCreatedSuccessful</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Facebook</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>create account success</string>
<key>people</key>
<dict>
<key>__set__</key>
<dict>
<key>account type</key>
<string>facebook</string>
<key>logged into account</key>
<true/>
</dict>
<key>__set_current_timestamp__</key>
<string>last logged in account</string>
</dict>
<key>properties</key>
<dict>
<key>_account_type</key>
<string>facebook</string>
<key>_flow</key>
<string>account</string>
</dict>
</dict>
<key>ABOY</key>
<dict>
<key>name</key>
<string>account_created_free2move</string>
<key>people</key>
<dict>
<key>logged_in_to_free2move</key>
<true/>
<key>has_free2move_account</key>
<true/>
</dict>
<key>properties</key>
<dict>
<key>account_type</key>
<string>facebook</string>
</dict>
</dict>
</dict>
<key>account.notification.declined</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>ButtonPressed</string>
<key>category</key>
<string>Account</string>
<key>label</key>
<string>Later</string>
</dict>
<key>MP</key>
<dict>
<key>name</key>
<string>later pressed</string>
<key>properties</key>
<dict>
<key>_flow</key>
<string>account</string>
</dict>
</dict>
</dict>
<key>account.notification.shown</key>
<dict>
<key>GA</key>
<dict>
<key>action</key>
<string>DialogueShown</string>
<key>category</key>';
my $regex = qr/(?U)\s*<key>GA\X*<\/dict>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}