const regex = /\bwith\s+(?!\P{P}*\bwith\b)(\P{P}+)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bwith\\s+(?!\\P{P}*\\bwith\\b)(\\P{P}+)', 'gu')
const str = `This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.
It should also work with a sentence finishing by a dot.
And what do we do with fruits? such as apples, pears and lemons?
Please come with this stuff:
- your laptop.
- a block of paper.
- a pencil.
I would not recommend sun bathing with just some oil!
I don't think you want to match "with" if it's in a string.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}