use strict;
my $str = 'This is a test with a string with punctuation, and an end. Then test words, and more text. And here whith more text with more punctuation, like that.
It should also work with a sentence finishing by a dot.
And what do we do with fruits? such as apples, pears and lemons?
Please come with this stuff:
- your laptop.
- a block of paper.
- a pencil.
I would not recommend sun bathing with just some oil!
I don\'t think you want to match "with" if it\'s in a string.';
my $regex = qr/\bwith\s+(?!\P{P}*\bwith\b)(\P{P}+)/up;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}