const regex = /^\(\s*[0-9]+\)\[[a-zA-Z0-9\s:]*\|\s*[0-9]{1,5}\:[0-9]{3}\s*(?:\[[0-9]{1,3}\:[0-9]{1,3}\])?\]\{[0-9]{1,4}\}[a-zA-Z0-9\s:@\/~]+\(?:.+\)[\$|#]\s{1}(?<!\n)(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(\\s*[0-9]+\\)\\[[a-zA-Z0-9\\s:]*\\|\\s*[0-9]{1,5}\\:[0-9]{3}\\s*(?:\\[[0-9]{1,3}\\:[0-9]{1,3}\\])?\\]\\{[0-9]{1,4}\\}[a-zA-Z0-9\\s:@\\\/~]+\\(?:.+\\)[\\$|#]\\s{1}(?<!\\n)(.+)$', 'gm')
const str = `( 8)[Thu Sep 01 09:44:38| 0:000]{157}jhyland@jhmac:~(✓)\$ whoami
( 8)[Thu Sep 01 09:44:42| 0:000]{158}jhyland@jhmac:~(✓)\$ uptime
( 8)[Thu Sep 01 09:44:45| 1:000]{159}jhyland@jhmac:~(✓)\$ pwd Documents/scripts/
( 8)[Thu Sep 01 09:44:51| 1:000]{160}jhyland@jhmac:~(✓)\$ false
( 8)[Thu Sep 01 09:44:54| 0:000]{161}jhyland@jhmac:~(123)\$ d
( 8)[Thu Sep 01 09:44:38| 0:000]{157}jhyland@jhmac:~(✓)\$ whoami
( 8)[Thu Sep 01 09:44:42| 0:000]{158}jhyland@jhmac:~(✓)\$ uptime
( 8)[Thu Sep 01 09:44:45| 1:000]{159}jhyland@jhmac:~(✓)\$ pwd Documents/scripts/
( 8)[Thu Sep 01 09:44:51| 1:000]{160}jhyland@jhmac:~(✓)\$ false
( 8)[Thu Sep 01 09:44:54| 0:000]{161}jhyland@jhmac:~(0)\$
( 7)[Thu Sep 01 09:17:30| 1:000]{1}jhyland@jhmac:~(✓)\$ man idk
( 7)[Thu Sep 01 09:17:32| 2:000]{2}jhyland@jhmac:~(0)\$ man file
( 7)[Thu Sep 01 09:50:51| 1998:000 [00:33]]{3}jhyland@jhmac:~(✓)\$
( 7)[Thu Sep 01 09:54:08| 0:000]{1}jhyland@jhmac:~(✓)\$ . ~/.bash_profile
( 7)[Thu Sep 01 09:54:14| 0:000]{2}jhyland@jhmac:~(✓)\$ return_code
( 7)[Thu Sep 01 09:54:17| 0:000]{3}jhyland@jhmac:~(0)\$ sudo su -
( 7)[Thu Sep 01 10:05:49| 0:000]{1}root@jhmac:~(✓)# whoami
( 7)[Thu Sep 01 10:06:24| 0:000]{2}root@jhmac:~(✓)# cd ~
( 7)[Thu Sep 01 10:06:29| 0:000]{3}root@jhmac:~(✓)# cd /tmp
( 7)[Thu Sep 01 09:54:08| 0:000]{1}jhyland@jhmac:~(✓)\$ . ~/.bash_profile
( 7)[Thu Sep 01 09:54:14| 0:000]{2}jhyland@jhmac:~(✓)\$ return_code
( 7)[Thu Sep 01 09:54:17| 0:000]{3}jhyland@jhmac:~(0)\$ sudo su -
( 7)[Thu Sep 01 10:05:49| 0:000]{1}root@jhmac:~(✓)# whoami
( 7)[Thu Sep 01 10:06:24| 0:000]{2}root@jhmac:~(✓)# cd ~
( 7)[Thu Sep 01 10:06:29| 0:000]{3}root@jhmac:~(✓)# cd /tmp
( 7)[Thu Sep 01 10:06:33| 0:000]{4}root@jhmac:/tmp(✓)# cd ~/.ssh/
( 7)[Thu Sep 01 10:15:35| 0:000]{5}root@jhmac:~/.ssh(✓)# exit
( 7)[Thu Sep 01 10:15:39| 591:000 [00:09]]{4}jhyland@jhmac:~(✓)\$ cd Documents/scripts/javascript/
( 7)[Thu Sep 01 10:15:44| 0:000]{5}jhyland@jhmac:~/Documents/scripts/javascript(✓)\$ ls`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}