const regex = /(?|(['"])[^\1]+?\1(,)?|([^,])(,))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|([\'"])[^\\1]+?\\1(,)?|([^,])(,))', 'g')
const str = `line1, "line2", "hello,world", 215, X + Y
line1, "line2", "hello,world", 215, X + Y, "hello,world", "um,dois,tres"
line1, "line2", "hello,world", 215, X + Y, "hello,world", "um,dois,tres",`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}