re = /(?|(['"])[^\1]+?\1(,)?|([^,])(,))/
str = 'line1, "line2", "hello,world", 215, X + Y
line1, "line2", "hello,world", 215, X + Y, "hello,world", "um,dois,tres"
line1, "line2", "hello,world", 215, X + Y, "hello,world", "um,dois,tres",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end