$re = '/(?|([\'"])[^\1]+?\1(,)?|([^,])(,))/';
$str = 'line1, "line2", "hello,world", 215, X + Y
line1, "line2", "hello,world", 215, X + Y, "hello,world", "um,dois,tres"
line1, "line2", "hello,world", 215, X + Y, "hello,world", "um,dois,tres",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);