package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s){!!(.*?)!!}`)
var str = `{!! random content between !!}`
var substitution = "{$1}"
fmt.Println(re.ReplaceAllString(str, substitution))
}