const regex = /{!!(.*?)!!}/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{!!(.*?)!!}', 'gs')
const str = `{!! random content between !!}`;
const subst = `{$1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);