use strict;
my $str = '{!! random content between !!}';
my $regex = qr/{!!(.*?)!!}/sp;
my $subst = '{$1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";