using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\s[^>]*href=(\""??)(http[^\"" >]*?)\\1[^>]*>(.*)<\/a>";
string input = @"<a href=""mailto:rudui@tes.com"">hi me</a>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}