$re = '/<a\s[^>]*href=(\"??)(http[^\" >]*?)\\\\1[^>]*>(.*)<\/a>/siU';
$str = '<a href="mailto:rudui@tes.com">hi me</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);