re = /<a\s[^>]*href=(\"??)(http[^\" >]*?)\\1[^>]*>(.*)<\/a>/i
str = '<a href="mailto:rudui@tes.com">hi me</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end