import re
regex = re.compile(r"(?:^\[FOR\](\w+)=(\d+).(\d+))|(?:\[NEXT\]((?1)))")
test_str = ("[FOR]FUNCO=1,99\n"
"Id funzionario per esempio #ID_FCCOD#\n"
"[NEXT]FUNCO\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")