using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{(?:(?:(?!\{\{|\}\}).)*+|(?R))+\}\}\s*";
string input = @"this is {{ remove {{ remove that }} }} a {{ remove }} sample {{ remove }} ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}