re = /\{\{(?:(?:(?!\{\{|\}\}).)*+|(?R))+\}\}\s*/
str = 'this is {{ remove {{ remove that }} }} a {{ remove }} sample {{ remove }} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end