$re = '/\{\{(?:(?:(?!\{\{|\}\}).)*+|(?R))+\}\}\s*/';
$str = 'this is {{ remove {{ remove that }} }} a {{ remove }} sample {{ remove }} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);