const regex = /\\{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\{2}', 'g')
const str = `{"files":{"windows":{"%windir%\\\\\\System32\\\\drivers\\\\etc\\\\lmhosts.sam":{"ignore":{"id":32}},"%windir%\\\\System32\\\\\\drivers\\\\etc":{"ignore":{"id":32}},"%windir%\\\\System32\\\\drivers\\\\etc\\\\hosts":{"ignore":{"id":32}}}}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}