// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\{2}").unwrap();
let string = "{\"files\":{\"windows\":{\"%windir%\\\\\\System32\\\\drivers\\\\etc\\\\lmhosts.sam\":{\"ignore\":{\"id\":32}},\"%windir%\\\\System32\\\\\\drivers\\\\etc\":{\"ignore\":{\"id\":32}},\"%windir%\\\\System32\\\\drivers\\\\etc\\\\hosts\":{\"ignore\":{\"id\":32}}}}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}