$re = '/\\\\{2}/';
$str = '{"files":{"windows":{"%windir%\\\\\\System32\\\\drivers\\\\etc\\\\lmhosts.sam":{"ignore":{"id":32}},"%windir%\\\\System32\\\\\\drivers\\\\etc":{"ignore":{"id":32}},"%windir%\\\\System32\\\\drivers\\\\etc\\\\hosts":{"ignore":{"id":32}}}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);