using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"errornode:\(TES\)([^\n]*).*";
string input = @"テストコメント3:
errornode:(TES)test_node_name
テストコメン ト4:";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}