$re = '/errornode:\(TES\)([^\n]*).*/m';
$str = 'テストコメント3:
errornode:(TES)test_node_name
テストコメント4:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);