// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)errornode:\(TES\)([^\n]*).*").unwrap();
let string = "テストコメント3:
errornode:(TES)test_node_name
テストコメント4:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}