const regex = /^(?!3570fefc-7049-49e8-99b4-ecfb3df79c27)(?!706bfe9f-4118-417a-8c18-691e06263c30)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!3570fefc-7049-49e8-99b4-ecfb3df79c27)(?!706bfe9f-4118-417a-8c18-691e06263c30)', 'gm')
const str = `706bfe9f-4118-417a-8c18-691e06263c30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}