re = /^(?!3570fefc-7049-49e8-99b4-ecfb3df79c27)(?!706bfe9f-4118-417a-8c18-691e06263c30)/m
str = '706bfe9f-4118-417a-8c18-691e06263c30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end