using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<match>""((\g<match>|[^""]*))*?"")(?=\s|\/)";
string input = @"<ListRows uniqueID=""2e43f3d6-82c1-4474-9b07-55632a55afd3"">
<description>
<expectedoutput>
<clear/>
</expectedoutput>
</description>
<diagnostics statistics=""On""/>
<clear/>
<ListRows uniqueID=""2e43f3d6-82c1-4474-9b07-55632a55afd3"" >
<description>
<expectedoutput>
<clear/>
</expectedoutput>
</description>
<diagnostics statistics=""On""/>
<clear/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}