$re = '/(?<match>"((\g<match>|[^"]*))*?")(?=\s|\/)/m';
$str = '<ListRows uniqueID="2e43f3d6-82c1-4474-9b07-55632a55afd3">
<description>
<expectedoutput>
<clear/>
</expectedoutput>
</description>
<diagnostics statistics="On"/>
<clear/>
<ListRows uniqueID="2e43f3d6-82c1-4474-9b07-55632a55afd3" >
<description>
<expectedoutput>
<clear/>
</expectedoutput>
</description>
<diagnostics statistics="On"/>
<clear/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);