use strict;
my $str = '<ListRows uniqueID="2e43f3d6-82c1-4474-9b07-55632a55afd3">
<description>
<expectedoutput>
<clear/>
</expectedoutput>
</description>
<diagnostics statistics="On"/>
<clear/>
<ListRows uniqueID="2e43f3d6-82c1-4474-9b07-55632a55afd3" >
<description>
<expectedoutput>
<clear/>
</expectedoutput>
</description>
<diagnostics statistics="On"/>
<clear/>';
my $regex = qr/(?<match>"((\g<match>|[^"]*))*?")(?=\s|\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}