package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{+([^{}]+)}\s*over\s*{([^{}]+)}+`)
var str = `{a} {b} over {c} {d}
{a} {{b} over {c}} {d}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}