re = /{+([^{}]+)}\s*over\s*{([^{}]+)}+/
str = '{a} {b} over {c} {d}
{a} {{b} over {c}} {d}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end